Membership is FREE!
It is best to log in before posting. Anonymous posting is disabled.

Viewing 1 to 10 (10 Total)
Squeaky and distorted sound with some sounds when DSP button is on

ThanhLoan7515

ThanhLoan7515
Canada

Total Posts: 44
Joined: September 13, 2014

Hi,
My KN7000 makes squeaky and distorted sound with some sounds (e.g. Spanish Guitar 1) when DSP button is on
Has anyone had this kind of problem ?
If I turn the Sound Load Off, the problem disappears.
All other sounds are OK ,

Anyone has any idea how to solve this problem ?

Thank you for your help

ThanhLoan

Tags:
Posted on November 5, 2016 at 3:05 PM
Display Messages: Threaded     Flat
9 Replies

davetutt

davetutt
United Kingdom

Total Posts: 166
Joined: January 12, 2015

Re: Squeaky and distorted sound with some sounds when DSP button is on

Hi there

The 7000 is a complex instrument that due to the age of them does suffer from a multitude of odd effects. Couple of things though. First is to connect the main outputs to an external amplifier system and see how it sounds through that. You can also do the same thing through a pair of decent headphones. If the sound is still wrong through either of these two alternative outputs there is really only one thing to do! With about 20 of these keyboards repaired in the past 18 months or so I know that all the odd things that occur can be cleared by some remedial work on the main preamp / power amp / power supply board known as the FAJ board slap bang in the middle of the keyboard.

I'm afraid if you do have an electronic fault its not exactly something you can do yourself unless you have electronic repair experience. If you want a guide you can give to a local repair person then I am only too happy to send some information on to you.

On rare occasions you may find that the sound you are trying to use excites a particular resonance in the on board speakers which may be either fluffy and in need of a dust out or perished around the outer edge (suspension) and it is only an audible effect in very specific situations as you have found. The only way to tell is to take the thing to pieces.

Sorry but the picture here isn't too good as I never thought so many people would want to know what to do!

Let me know how you get on and perhaps we can sort it for you.

Regards

Dave

Attachments: IMGP1164.JPG
Posted on November 5, 2016 at 8:31 PM

ThanhLoan7515

ThanhLoan7515
Canada

Total Posts: 44
Joined: September 13, 2014

Re: Squeaky and distorted sound with some sounds when DSP button is on

Thanks Dave for your reply and for the hints.
Your observation is very sound and relevant as the problem comes and goes. Maybe it is caused by resonance and vibration of some kind.
I will open up my 7000 and give it a cleaning job (dusting out, reseating connectors etc) and will update this post.

Thanh

Posted on November 6, 2016 at 5:16 AM

davetutt

davetutt
United Kingdom

Total Posts: 166
Joined: January 12, 2015

Re: Squeaky and distorted sound with some sounds when DSP button is on

There are a few other potential sources of this sort of thing which I hope are not the cause of your problem. Over the years (more than I care to remember!) I have found issues with soldering of the DAC chips, soldering on some of the LSI chips, and some rare issues with capacitors on reference voltages.

Let me know what you find. Looking forward to hear your news!

Regards

Dave

Posted on November 6, 2016 at 6:43 PM

ThanhLoan7515

ThanhLoan7515
Canada

Total Posts: 44
Joined: September 13, 2014

Re: Squeaky and distorted sound with some sounds when DSP button is on

Thanks Dave,
I will exercise all options and report results in due time.
Thanh

Posted on November 7, 2016 at 4:24 AM

ThanhLoan7515

ThanhLoan7515
Canada

Total Posts: 44
Joined: September 13, 2014

Re: Squeaky and distorted sound with some sounds when DSP button is on

I complete the basic first step of diagnosing my problem by executing all the KN7000 built-in tests and the good news is, it passed all the tests including the DSP and sound test.
It's a good sign because I was initially afraid that the DSP chip is corrupted.

The next step will be what I plan to do : open up and give it a cleaning job `dusting out and re-seating the connectors.
Stay tune !

Thanh

Posted on November 7, 2016 at 9:54 PM

ThanhLoan7515

ThanhLoan7515
Canada

Total Posts: 44
Joined: September 13, 2014

Re: Squeaky and distorted sound with some sounds when DSP button is on

I followed Dave's advise and the squeaking distorted sound was heard in my Sennheiser headset.
I forgot to mention that the problem disappears when I set DSP to Off. As soon as I press the DSP button, the problem came back.
I suspect the FAJ board is the culprit.
David : Do I have to replace the FAJ or it is repairable ?

Once again, thank you for your help...
Thanh

Posted on November 8, 2016 at 2:30 AM

ThanhLoan7515

ThanhLoan7515
Canada

Total Posts: 44
Joined: September 13, 2014

Re: Squeaky and distorted sound with some sounds when DSP button is on

Further test :
1. Open it up, clean and dust out with compressed air, reseat connectors that are reseatable
2. Remove all the speakers, no sign of oxidation on connectors or around outer edge of the the speakers coil

No improvement to my problem.

New observations :
- the squeaking sound comes out only on the left side speakers.
- and this problem is present only when Sound DSP button is on and mostly
- and particularly, the problem is present only on the Conductor Right 1 .

Dave and anyone : Do you have any idea about the cause of this problem ?
Dave : Do you have any repair shop around my area in Montreal, Canada ?

Thank you

Posted on November 9, 2016 at 4:17 PM

ThanhLoan7515

ThanhLoan7515
Canada

Total Posts: 44
Joined: September 13, 2014

Re: Squeaky and distorted sound with some sounds when DSP button is on

Correction :
The problem is present with all Conductor sounds Left, Right 2, Right 1 but particularly with Left, the problem is present regardless of the Sound DSP is On or Off.

Posted on November 9, 2016 at 4:55 PM

ThanhLoan7515

ThanhLoan7515
Canada

Total Posts: 44
Joined: September 13, 2014

Re: Squeaky and distorted sound with some sounds when DSP button is on

Other observations on my problem :
After turning on, when I hit any key, a high clicking sound is heard thru the speakers.
The sound is similar to a static electricity discharge from a capacitor.
After playing a few minute, when I change the sound, the clicking sound is heard again.

Does anyone know what capacitor is the culprit ?

Thank you

Posted on November 10, 2016 at 7:52 PM